Tag Archives: Archimedes

Making the Old work with the New

P505

Yesterday, I took my Acorn A305 – a 25 year old computer – to another Paul who has developed a rather cunning way of getting these old machines to display correctly on a modern LCD monitor.

After some soldering (a skill I have not developed) and some detective work with some jumpers (used to various control signals to/from the video circuitry), the machine’s upgrade was completed, and we got a display on an LCD screen. I say “we” – Paul was the one doing most, if not all, of the work here.

The really clever bit is that the modification is software controlled, so no need for manual switching. The software knows what signal to send to the monitor and flips the added hardware as required. So it’s invisible to the user. Clever stuff indeed.

For more on this, visit Paul’s website: http://www.retro-kit.co.uk/VIDC-Enhancer/

These are now available to buy: http://www.retro-kit.co.uk/site_news.cfm#NewsID38

Reviving an Archimedes

The other week, I switched on an old computer – my Acorn Archimedes (http://en.wikipedia.org/wiki/Acorn_Archimedes). It’s a 300 series machine, which makes it 24 years old. It started up, then started again, then again and then went dead. It hadn’t been started for a few years and knowing that the BBC Micro has problems with the power supply unit when it’s been left for a long time (they tend to blow capacitors), I suspected that this was the case here.

Acorn_computers_-_l1010507

So, myself and a friend, Chris, set to to find out what was wrong. I’m not an electronics expert, and I certainly have no skills with a soldering iron, but Chris can do all of this, and a lot more, so between us we took the machine apart and started testing. As we went, I took pictures – mostly for reference – so we knew where the bits, wires, etc. had to go when reassembling. The PSU was the main suspect, but initial tests showed that it was supplying power – all the right voltages came out from the right connectors. It seemed that there was a problem somewhere else – very likely on the main circuit board.

In fact, it seemed that the machine booted up when the 12v supply was not connected. All that could be gleaned from the circuit diagram that I’d downloaded from http://www.drobe.co.uk was that this powered the fan, and sent some juice to the backplane. On the stripped down circuit board, it seemed that there was all the 12v supply did. The fan connector is unoccupied on a base A300 series machine, but on mine it’s used to blow air over the hard drive I’d installed, so it’s necessary.

So, while Chris followed tracks, I followed Google. I found this link: http://forums.nekochan.net/viewtopic.php?f=8&t=16721049 where the original poster lists some symptoms about an A300 series: &ldquoSadly it didn’t start – the PSU buzzed at switch on – this was traced to a shorted tant. cap in the 12V rail.” That was the clue. This machine was doing exactly the same thing.

The_capacitor_-_l1010512
The_capacitor_-_l1010509

Chris said that the capacitor in question was regulating voltage on the circuit, possibly to cancel noise or smooth out the power supply. To me it sounded a bit like an angry appendix. Anyway, what it now appeared to be doing was causing a short circuit, and this in turn was making the PSU go into some kind of protection mode. So Chris removed the capacitor, and cleared the area from shorts.

And_its_gone_-_l1010513

We then started the process of reassembling the machine, slowly and testing start up at various points along the rebuild. It started up every time – the machine, it appears, has been saved.

The capacitor is this small, yellow blob-like thing. It looks OK from the outside, but it’s probably mashed inside. This is the culprit.

The_capacitor_-_l1010515

A set of photos of the internals of the machine can be found here.

When I got the machine home, I tried booting it again, and it started up first time, and it seems that removing the capacitor was all that was needed to restore functionality.

For those who are interested, Chris highlighted the errant component on the circuit diagram in red:

Img004